How to disable default share in XP

軟體下載站推薦, 軟體介紹, 支援及問題解答
User avatar
willy
Knight-Captain 上尉騎士
Knight-Captain 上尉騎士
Posts: 1062
Joined: Sun Oct 19, 2003 12:38 pm
Contact:

How to disable default share in XP

Postby willy » Tue Jul 02, 2013 11:53 pm

The system automatically creates hidden “administrative shares” for its logical drives C:, D:, and so forth which it names C$, D$ and so forth. It also creates the admin$ hidden share for to the \winnt or windows folder. These shares are designed for remote access support by domain administrators. By default, if you delete these admin shares, they will be recreated when you reboot. To disable permanently so they will not be recreated on the next reboot, use the following procedure.


Note:- Before doing this procedure please take a complete registry backup

For Workstations (Vista/XP/2000)

Click Start—>Run type regedit click ok

For vista users Enter your UAC credentials to continue.

Open the HKEY_LOCAL_MACHINE branch.

Open the SYSTEM branch.

Open the CurrentControlSet branch.

Open the Services branch.

Open the LanmanServer branch.

Select the Parameters branch.

Select Edit, New, DWORD (32-bit) Value. Vista adds a new value to the Parameters key (If you have the key just check for correct value).

Type AutoShareWks and press Enter. (You can leave this setting with its default value of 0.)

Restart Windows to put the new setting into effect.

Solution 2

In Windows 2000 and Windows XP, you disable the shares via

Start —>Settings —>Control Panel
Systems Tools panel
Shared Folders
Double-click the Shared Folders branch to expand it
Click Shares
In the Shared Folder column, right-click the share you want to disable
Click Stop sharing
Cick OK.

For Servers (2003/2000)

Click Start—>Run type regedit click ok

Open the HKEY_LOCAL_MACHINE branch.

Open the SYSTEM branch.

Open the CurrentControlSet branch.

Open the Services branch.

Open the LanmanServer branch.

Select the Parameters branch.

Select Edit, New, DWORD (32-bit) Value. Vista adds a new value to the Parameters key (If you have the key just check for correct value).

Type AutoShareServer and press Enter. (You can leave this setting with its default value of 0.)

Restart Windows to put the new setting into effect.

Who is online

Users browsing this forum: No registered users and 1 guest